用户名:密 码:注册|找回密码设置首页 | 中国股市论坛

当前位置 > 中国股市在线 > 股市动态 > 主力动向 > 大智慧主力动向源码

大智慧主力动向源码

发布时间:2017-09-22 20:09来源:互联网作者:Robot editing字号:

以下是大智慧主力动向源码(无源码的请下载附件导入)

大智慧主力动向源码

DRAWGBKlast(DATE>900101,strip(RGB(0,0,160),RGB(0,20,10),0));
DRAWGBK(c,'20' );
CC1:=(2*CLOSE+HIGH+LOW+OPEN)/5;
CC2:=(2*INDEXC+INDEXH+INDEXL+INDEXO)/5;
C1:=CC1/CC2;
O1:=C/INDEXC;
O2:=O/INDEXO;
ZLDX:MA(C1,4),LINETHICK2;
PARTLINE(ZLDX,(ZLDX>REF(ZLDX,1))-1,rgb(0,255,0),1,rgb(255,0,0) ),LINETHICK2;
STICKLINE(C1>=O1 AND C1>ZLDX,C1,ZLDX,6,0),COLORRED;
STICKLINE(C1>=O2 AND C1>ZLDX,C1,ZLDX,6,1),COLORFF00FF;
STICKLINE(C1<O1 AND C1<=ZLDX ,ZLDX,C1,6,0),COLORCYAN;
STICKLINE(C1<O2 AND C1<=ZLDX ,ZLDX,C1,6,1),COLOR00FFFF;
DRAWFLAGTEXT( ZLDX>REF(ZLDX,1),ZLDX, '当ZLDX红变绿时 K线与ZLDX 阳,阴或大,小相反 警惕要下跌!! '),COLOR00FF00;
DRAWFLAGTEXT( ZLDX>REF(ZLDX,1),ZLDX, '当ZLDX上升变缓或放平, 警惕要下跌!! 当ZLDX红变绿时 警惕要下跌!! '),COLORFF00FF;

{
《主力动向》使用说明:
本公式简洁明快,仅包含两条波浪线(白色的C1和红绿相间的主力动向线ZLDX)和一组红蓝相间的柱线。
1、红线+红柱,持股;
红线+蓝柱,离场;
2、原则上绿线空仓:
绿线+红柱,观望;
绿线+蓝柱,离场;
但绿线向上,且白线并未下穿绿线,仍然持股;
3、股价上涨,但红柱并未随着增长,动向线由向上趋势而走平甚至向下,后市看跌;
股价创新高,而红柱消失,立即清仓;
4、股价下跌,但红柱增长,动向线由向下趋势而走平甚至向上,后市看涨;
股价创新低而蓝柱消失,立即全仓。};
年1:=YEAR;
月1:=MONTH;
日1:=DAY;
星期:=WEEKDAY;
时:=HOUR;
分:=MINUTE;
秒:=TIME;
DRAWTEXTREL(1,910,NUMTOSTR(年1)+'年'+NUMTOSTR(月1)+'月'+NUMTOSTR(日1)+'日 星期'+NUMTOSTR(星期)+
' 北京时间 '+STRLEFT(NUMTOSTRN(IF(CURRENTTIME<10000,0,CURRENTTIME),0),IF(CURRENTTIME>=10000 AND
CURRENTTIME<100000,1,2))+'点 '+STRMID(NUMTOSTRN(CURRENTTIME,0),IF(CURRENTTIME<10000,1,IF(CURRENTTIME>=10000 AND
CURRENTTIME<100000,2,3)),2)+'分 '+STRRIGHT(NUMTOSTRN(CURRENTTIME,0),2)+'秒'),LINETHICK2,COLORyellow;

大智慧主力动向源码

(郑重声明:内容独家供稿,转载请注明出处)